Payments cannot be processed
Incident Report for FleetMon
Resolved
All problems should be fixed. The booking process should work as expected.
Posted Sep 06, 2022 - 12:49 CEST
Identified
Currently no purchases can be made. We are working on solving this as quick as possible. In the meantime you can still create a free ‘Starter’ Account and upgrade later or contact the sales team for a paid plan or FleetMon Credit Points. support@fleetmon.com

Sorry for the inconvenience!
Posted Sep 05, 2022 - 15:46 CEST