Short-term maintenance
Incident Report for FleetMon
Resolved
FleetMon website and Customer APIs are available again.
Posted over 4 years ago. Nov 24, 2014 - 10:25 CET
Investigating
FleetMon website and customer APIs will be unavailable for a short time as our engineers are working on an immediate load issue. We expect this to last no longer than 5 minutes.
Posted over 4 years ago. Nov 24, 2014 - 10:19 CET