Maintenance Mode, short-term
Incident Report for FleetMon
Postmortem

Following on the IP routing issues earlier this week, which FleetMon's team had no control of, a short downtime with partial unavailability of FleetMon.com, Explorer and Customer APIs occurred in the early hours this morning.

The outage today was technically due to issues on the operating system level, such issues being not uncommon and usually quickly met with failover and alerting mechanisms as part of our daily routine.

Today, our monitoring system was not fully operational due to short-noticed maintenance in the respective datacenter, which is intentionally different from the datacenter hosting the FleetMon platform itself.

The outage today happened during the maintenance period of the monitoring system, so the alerts did not get properly raised and routed to our DevOps team, who, when alerted, where able to fix the issue within minutes.

We will review both incidents internally with due diligence and implement proper measures, as far as in our control, in due course.

Posted almost 5 years ago. Oct 31, 2014 - 11:35 CET

Resolved
IP routing problems have been solved. All systems are fully operational again.
Posted almost 5 years ago. Oct 29, 2014 - 12:34 CET
Monitoring
FleetMon Explorer is operational again. We are monitoring the systems for remaining glitches in network communication.
Posted almost 5 years ago. Oct 29, 2014 - 08:23 CET
Identified
The issue could be traced back to IP routing problems in our commercial datacenter which we are currently working around. FleetMon website and Customer API are operationaly again, FleetMon Explorer next.
Posted almost 5 years ago. Oct 29, 2014 - 07:48 CET
Investigating
The FleetMon website has been switched to maintenance mode for a few minutes while our engineers are working on an immediate capacity issue. AIS data processing and FleetMon Satellite Tracking are not affected.
Posted almost 5 years ago. Oct 29, 2014 - 07:31 CET